Danfoss ally

Tags: #<Tag:0x00007fc6bb5a93d8>

Bonjour. Je viens d inclure une vanne danfoss ally mais je ne sais pas comment la faire fonctionner .les commandes on l air étranges . Pouvez-vous m aider svp . Merci .ally.pdf (143,9 Ko)ally2

Tu choisis un des trois modes proposés (en cliquant dessus) et une consigne de chauffe (la valeur de température requise).
C’est tout , pas plus pas moins.

Le nom des commandes et modes est celui par défaut retourné par ton équipement . Tu peux les modifier , dans la table de configuration des commandes ou choisir de ne pas les afficher ou mieux leur affecter un widget dédié comme ceux proposés par @Salvialf sur ce forum.

Derniers petit conseils :

  1. Lis la doc Jeedom pour faire le look and feel que tu souhaites (design, widget, plug in, …)
  2. Voir ici si tu veux une aide plus personnalisée : Comment nous aider à vous aider - ou Comment poser une bonne question?
  3. Pratique le tutoriel des nouveaux arrivants du forum c’est fait pour et ça te permetra de mieux inclure ce qui est demandé au conseil 2)

Merci pour votre réponse . J ai essayé de trouver une réponse sur le forum mais sans succès . Lorsque je clic sur une commande j ai un message d erreur 6 : paramètre non valide . Si quelqu’un pouvait me faire une capture d écran avec les différentes commandes et les valeurs , ça m aiderais peut être car je débute et je n y connais rien .Merci .(voir aussi le pdf dans mon premier message)

Bien relire (puis appliquer surtout pour les néophytes) le point 2) de mon message précédent :wink:

Mais enfin ! Je ne demande pas la lune ! ça fait deux jours que j essaie d utiliser cette vanne que d autres personnes utilisent. Je demande juste une capture d écran pour comparer les commandes. C est quand même un forum d entraide !

Je vais tenter de rester poli (plutôt une bonne habitude à prendre et à conserver) mais si tu as lu alors tu as du voir ceci (exemple parmis d’autres que tua s du louper)

:one::zero: Indiquez le matériel et la version sur laquelle Jeedom tourne.

Dites nous si vous tournez sur un Raspberry et sa version, sur une VM, quel hyperviseur, une installation Docker, autre matériel. Ensuite indiquez aussi la version du core de Jeedom et la version de votre Debian (beaucoup de ces infos se retrouvent dans la page Santé de votre Jeedom).

Exemple:

  • Jeedom 3.14.15 sur un Rapsberry Pi 3b+ tournant sur un disque SSD sous Debian Stretch 9.5
  • Jeedom 4.44.7 tournant sur une VM proxmox en utilisant l’image Debian buster x64 10.1.1
  • Jeedom 3.14.15 sur un Docker Synology en utilisant l’image officielle de Jeedom
  • Jeedom 4.0.12 sur la Freebox delta, installé en utilisant le tuto du site http://www.tartempion-fait-de-la-domotique.fr

Rappelez-vous que des mots comme la dernière version , celle de ce matin , la version actuelle etc ne sont pas des numéro de version et changent dans le temps.

Bonjour,
Il manque également le tag du plug-in. Donner le plug-in utilisé me semble relevant pour une question sur une intégration de périphérique.

En faisant moi une recherche, car ce n’est pas dit, je suppose que le protocol de la tête de vanne est du zigbee mais il existe plusieurs plug-in pour cela.

Bonjour. Cette vanne foctionne en zigbee avec une conbee 2 v2.07.01 F26680700 et le plugin deconz . je fais tourner jeedom 4.0.61 sur VM sur synology. Je vois la vanne sur jeedom mais sur la page de commande , ça na pas l air correct .C est pour ça que je demande a un utilisateur de cette vanne une copie d ecran de la page de commande pour pouvoir comparrer . Lorsque je veux changer un mode de cette vanne , j ai un message d erreur de commande .Merci .Cordialement .

Comme tu n’indiques pas le message d’erreur et que tu ne joins pas les logs Deconz difficile d’en dire plus.

ça veut dire quoi ?

ça veut dire quoi ?

La page de commandes que tu as mise en copie est elle celle générée automatiquement lors de l’appairage de la vanne ?

As tu d’autres capteurs ou actionneurs qui fonctionnent avec Deconz ?.

je viens d avoir une copie d écran d un utilisateur . je vais tester car les commande générées automatiquement sur mon jeedom ne sont pas du tout les même .

Voila se que j ai pu trouvez de deconz :

Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).
[2020-12-29 08:54:23][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Auto 01-0201] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/sensors/6/config(PUT), data : {"mode":"auto"} erreur : 6 => parameter, mode, not available
[2020-12-29 08:55:26][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Auto 01-0201] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/sensors/6/config(PUT), data : {"mode":"auto"} erreur : 6 => parameter, mode, not available
[2020-12-29 09:48:27][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Auto 01-0201] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/sensors/6/config(PUT), data : {"mode":"auto"} erreur : 6 => parameter, mode, not available
[2020-12-29 11:47:56][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Auto] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/sensors/6/config(PUT), data : {"mode":"auto"} erreur : 6 => parameter, mode, not available
[2020-12-29 11:48:01][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Boost] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/sensors/6/config(PUT), data : {"mode":"heat"} erreur : 6 => parameter, mode, not available
[2020-12-29 11:48:03][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Off] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/sensors/6/config(PUT), data : {"mode":"off"} erreur : 6 => parameter, mode, not available

Dans ta config initiale (celle en copie de ton premier message) passe le type de toutes tes commandes action à Lumière au lieu de Capteur

C’est le log Deconz qui le confirme. Il y a inversion de type ce qui provoque l’erreur.t

Je viens d essayer mais toujours messages d erreur .

[[2020-12-29 12:02:52][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Auto] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/lights/6/config(PUT), data : {"mode":"auto"} erreur : 4 => method, PUT, not available for resource, /lights/6/config [2020-12-29 12:04:53][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Auto] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/lights/6/config(PUT), data : {"mode":"auto"} erreur : 4 => method, PUT, not available for resource, /lights/6/config [2020-12-29 12:05:01][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Boost] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/lights/6/config(PUT), data : {"mode":"heat"} erreur : 4 => method, PUT, not available for resource, /lights/6/config [2020-12-29 12:05:05][ERROR] : Erreur exécution de la commande [salle à manger][Thermostat 6][Mode Off] : Erreur lors de la requete : 127.0.0.1:8484/api/8FE2467DF1/lights/6/config(PUT), data : {"mode":"off"} erreur : 4 => method, PUT, not available for resource, /lights/6/config

Pour le moment , je n ai que ce module en zigbee pour tester le stick .

Quel est le type de la vanne vue sous Phoscon (si tant est qu’elle soit connue de Phoscon)? Light ou Sensor ?
Repasse les commandes en Sensor en attendant.
Visiblement le paramètre Mode n’est pas connu de l’interface REST API.
Peut tu poster ici la copie des informations brutes de la vanne ?

ally3 info

Donc la vanne est bien vue comme un Sensor (Capteur) et pas comme une Light (Lumière)

Pour les infos brutes c’est dans Equipement/Configuration/InformationsBrutes lorsque tu sélectionnes ta vanne dans Deconz

{
    "6": {
        "config": {
            "battery": 72,
            "displayflipped": null,
            "heatsetpoint": 2600,
            "locked": null,
            "mountingmode": null,
            "offset": 0,
            "on": true,
            "reachable": true
        },
        "ep": 1,
        "etag": "475c414d3b93916a6d76ba9f8530e5f3",
        "lastseen": "2020-12-29T11:26Z",
        "manufacturername": "Danfoss",
        "modelid": "eTRV0100",
        "name": "Thermostat 6",
        "state": {
            "errorcode": null,
            "lastupdated": "2020-12-29T11:26:04.201",
            "mountingmodeactive": false,
            "on": true,
            "temperature": 2610,
            "valve": 34,
            "windowopen": "Closed"
        },
        "swversion": "01.02.0008 01.02",
        "type": "ZHAThermostat",
        "uniqueid": "14:b4:57:ff:fe:d3:e0:7e-01-0201"
    },
    "7": {
        "config": {
            "battery": 72,
            "on": true,
            "reachable": true
        },
        "ep": 1,
        "etag": "0f154ebe1c3191f6985c9236771042ae",
        "lastseen": "2020-12-29T11:26Z",
        "manufacturername": "Danfoss",
        "modelid": "eTRV0100",
        "name": "Time 7",
        "state": {
            "lastset": "2020-12-29T07:44:15Z",
            "lastupdated": "2020-12-29T07:53:28.495",
            "localtime": "2020-12-29T08:53:24",
            "utc": "2020-12-29T07:53:24Z"
        },
        "swversion": "01.02.0008 01.02",
        "type": "ZHATime",
        "uniqueid": "14:b4:57:ff:fe:d3:e0:7e-01-000a"
    }
}

Mets le contenu en forme en sélectionnant le texte puis en cliquant sur </> sinon c’est illisible.
A première vue les commandes actions 01-0201.config::mode devraient plutôt être 01-201.config::mountingmode

ça a changé la quelque chose pour la mise en forme ?