Comment se connecter uniquement depuis l'IP interne?

Bonjour,
J’ai créé un nouveau compte, appelé ‹ home › et je souhaite qu’on ne puisse que se connecter à celui-ci depuis l’IP interne, comment fait-on ?

J’ai essayé l’option Local se trouvant dans Jeedom:
image
Mais cela ne fonctionne pas, je ne peux alors ni me connecter avec home via l’IP interne, ni l’IP externe. A quoi sert cette option du coup?
Merci

Bonjour,

Si cette option sert à vérouiller l’utilisateur à se connecter qu’en local (c’est à dire sur le même réseau que ta box domotiqe). C’est ce que j’ai fais pour ma tablette dédier domotique, j’ai crée un utilisateur local avec un profil utilisateur (donc sans restrinction sauf développement).

Cdlt.

1 J'aime

Je suis content d’apprendre que c’est possible :grinning:

Mais je viens de sélectionner à nouveau l’option Local pour mon utilisateur ‹ home ›, je confirme que cela ne fonctionne pas. Lorsque cette option est sélectionné: je ne peux plus du tout me loguer sur le compte ‹ home ›, ni via l’IP interne, ni via l’IP externe, ni même en direct sur le serveur Jeedom :sob:

Tu as installer jeedom sur quelle équipement ? as-tu mis un IP fixe ? comment procéde tu pour te connecter à jeedom ?

Moi je suis sur rasberry, j’ai prog un IP fixe via debian, lorsque je vais sur l’interface jeedom en tapent l’IP dans la bar URL d’internet, je tombe sur jeedom, puis je me log avec mon compte « tablette » et le mdp que j’ai défini. Lorsque je me connecte à distance sur mon serveur via URL distant que jeedom donne, si j’essaie de me logger avec mon compte « tablette » cela ne marche pas car j’ai sélection « local ».

1 J'aime

J’ai installé Jeedom v4.0 sur un PC Windows 10 via VirtualPC. Jeedom est sous Debian (dernière version).
Ma machine virtuelle est en NAT et j’ai redirigé le port 80 afin d’accéder à Jeedom:
image
J’accède donc à Jeedom ainsi : http://192.168.1.11/ (192.168.1.11 étant l’adresse IP du PC Windows 10)

Personnellement je mettrai ton réseau en « accès par pont » comme sa tu aurais ton propre IP pour ta virtualbox et donc ton propre IP pour ta box domotique. Sa devrait peut-etre résoudre ton problème.

1 J'aime

Est ce que tu as defini des droits a ton utilisateur ?

Si tu as choisi « utilisteur limité » comme sur ton screenshop, il faut ensuite lui octroyer des droits

Même s’il est en « utilisateur limité » sa ne devrait pas l’empécher de se loger avec son compte local. Je pense que c’est le fait d’etre mode réseau « native » avec le redirection de port. Je ne sais pas trop comment se comporte la virtualbox en native mais vu qu’il y a une redirection de port je pense que n’est pas vraiment en « local » quand il se connecte sur son jeedom donc normal qu’il arrive pas à se loger. Le faite de passer en « part pont » et je mettre un IP fixe via debian devrai résoudre le problème.

2 J'aimes

Exact, si sa VM est dans un sous-réseau différent (dû au NAT), il n’est en fait jamais en local.

En passant, @jeehome l’utilisateur « admin » par défaut devrait aussi être « local » au minimum (voir désactivé) mais à ne pas faire ici sans avoir un autre utilisateur ou avoir réglé ce problème sinon la porte sera « définitivement » fermée :wink:

1 J'aime

Je viens de faire les modifications pour être en Accès par Pont à la place de NAT:
image

Malheureusement cela ne change rien, je ne peux toujours pas me connecter :sob: avec mon utilisateur home lorsque l’option Local est sélectionnée.

tu as défini une adresse IP masque sous réseau etc… sur débian du coup ?

Non, c’est quoi une adresse IP masque de sous réseau? et comment on fait?

Adresse IP est une adresse unique pour joindre ton équipement, par exemple tu peux mettre 192.168.1.100
Masque sous réseau défini le réseau chez toi, généralement 255.255.255.0
et la paserelle c’est l’adresse IP de ton roteur, par exemple si c’est une box orange c’est 192.168.1.1
tu dois modifier via ligne de commande dans ton serveur debian

IP statique sur raspberry

Tu tape la commande suivant :

sudo nano /etc/dhcpcd.conf

Tu descend en bas du fichier de config et tu met ça pour suivre l’exemple du dessus :

interface eth0
static ip_address=192.168.100.4/24
static routers=192.168.1.1

puis tu tape : ctrl + o / entrer / ctrl + x

tu redémarre ton serveur et sa devrais fonctionner

J’ai saisi ces infos dans le fichier /etc/dhcpcd.conf:

interface eth0
static ip_address=192.168.1.20/24
static routers=192.168.1.1

J’ai une Livebox et 192.168.1.20 est l’IP statique de mon Debian Jeedom. J’ai redémarré Jeedom.

J’ai essayé de me connecter avec l’utilisateur ‹ home › et j’ai toujours le même problème, Jeedom refuse quand l’option Local est sélectionnée:
image

question bète, tu as supprimé les redirections de port ?

Oui, j’ai bien supprimé la redirection des ports comme je n’ai plus de NAT.

tu tape bien dans ton navigateur weeb 192.168.1.20 ?

Quand tu te connecte a ta livebox, tu vois bien apparaitre dans le réseau ton jeedom ?

Oui, je tape bien cela:
image

et sur la Livebox je vois bien Jeedom

tu peux faire une capture du réglage de ta virtualbox ? ton ordinateur(ou se trouve ta VM) est branché en wifi ou cable éthernet ?