[CloudSyncPro] Plus de sauvegarde sur FTP depuis quelques jours

Tags: #<Tag:0x00007f38585c0e58>

Hello @thanaus,

Ma dernière sauvegarde réussie date du 30 juillet. Depuis (un backup tous les matins), rien.

Voici les logs :

[2020-08-03 15:56:34][DEBUG] : postSave:: this:cloudsyncpro::__set_state(array(    'id' => '127',    'name' => 'SauvegardeFTP',    'logicalId' => '',    'generic_type' => NULL,    'object_id' => '16',    'eqType_name' => 'cloudsyncpro',    'eqReal_id' => NULL,    'isVisible' => '0',    'isEnable' => '1',    'configuration' =>    array (     'createtime' => '2019-08-23 11:13:48',     'type' => 'ftp',     'param1' => 'monsite.com',     'param2' => '21',     'param3' => 'jeedom@monsite.com',     'param4' => ‘xxxxxxxxxx’,     'updatetime' => '2020-08-03 15:40:59',     'sendToHomebridge' => '0',     'comment' => '',   ),    'timeout' => NULL,    'category' =>    array (     'heating' => '0',     'security' => '0',     'energy' => '0',     'light' => '0',     'automatism' => '0',     'multimedia' => '0',     'default' => '0',   ),    'display' => '{"height":"110px","width":"230px"}',    'order' => '9999',    'comment' => NULL,    'tags' => NULL,    '_debug' => false,    '_object' => NULL,    '_needRefreshWidget' => false,    '_timeoutUpdated' => false,    '_batteryUpdated' => false,    '_changed' => false, ))
[2020-08-03 15:56:34][DEBUG] : loadConfigFile::
[2020-08-03 15:56:34][DEBUG] : loadConfigFile:: rclone.conf:array (   127 =>    array (     'type' => 'ftp',     'host' => 'monsite.com',     'user' => 'jeedom@monsite.com',     'port' => '21',     'pass' => 'monpass',   ), )
[2020-08-03 15:56:34][DEBUG] : saveConfigFile:: array:array (   127 =>    array (     'type' => 'ftp',     'host' => 'monsite.com',     'user' => 'jeedom@monsite.com',     'port' => '21',     'pass' => 'monpass',   ), )
[2020-08-03 15:56:34][DEBUG] : saveConfigFile:: content:'[127] type = ftp host = monsite.com user = jeedom@monsite.com port = 21 pass = monpass  '
[2020-08-03 15:56:44][DEBUG] : execute:: options:NULL
[2020-08-03 15:56:44][DEBUG] : execute:: this:cloudsyncproCmd::__set_state(array(    'id' => '908',    'logicalId' => NULL,    'generic_type' => NULL,    'eqType' => 'cloudsyncpro',    'name' => 'SaveFTP',    'order' => '0',    'type' => 'action',    'subType' => 'other',    'eqLogic_id' => '127',    'isHistorized' => '0',    'unite' => '',    'configuration' =>    array (     'command' => 'copy',     'source' => '/var/www/html/backup',     'destination' => '/jeedom-bk',     'include' => '',     'exclude' => '',     'minage' => '',     'maxage' => '',   ),    'template' => '{"dashboard":"core::default","mobile":"core::default"}',    'display' => '{"invertBinary":"0","showStatsOnmobile":0,"showStatsOndashboard":0}',    'value' => NULL,    'isVisible' => '1',    'alert' => '[]',    '_collectDate' => '',    '_valueDate' => '',    '_eqLogic' =>    cloudsyncpro::__set_state(array(      'id' => '127',      'name' => 'SauvegardeFTP',      'logicalId' => '',      'generic_type' => NULL,      'object_id' => '16',      'eqType_name' => 'cloudsyncpro',      'eqReal_id' => NULL,      'isVisible' => '0',      'isEnable' => '1',      'configuration' => '{"createtime":"2019-08-23 11:13:48","type":"ftp","param1":"monsite.com","param2":"21","param3":"jeedom@monsite.com","param4 »: »xxxxxxxxx », »updatetime":"2020-08-03 15:40:59","sendToHomebridge":"0","comment":""}',      'timeout' => NULL,      'category' => '{"heating":"0","security":"0","energy":"0","light":"0","automatism":"0","multimedia":"0","default":"0"}',      'display' => '{"height":"110px","width":"230px"}',      'order' => '9999',      'comment' => NULL,      'tags' => NULL,      '_debug' => false,      '_object' =>      jeeObject::__set_state(array(        'id' => '16',        'name' => 'Mobile et software',        'father_id' => NULL,        'isVisible' => '1',        'position' => '17',        'configuration' => '{"parentNumber":0,"tagColor":"#000000","tagTextColor":"#FFFFFF","desktop::summaryTextColor":"","mobile::summaryTextColor":"","hideOnDashboard":"0","summary::global::security":"0","summary::global::motion":"0","summary::global::door":"0","summary::global::windows":"0","summary::global::shutter":"0","summary::global::light":"0","summary::global::outlet":"0","summary::global::temperature":"0","summary::global::humidity":"0","summary::global::luminosity":"0","summary::global::power":"0","summary::hide::desktop::security":"0","summary::hide::desktop::motion":"0","summary::hide::desktop::door":"0","summary::hide::desktop::windows":"0","summary::hide::desktop::shutter":"0","summary::hide::desktop::light":"0","summary::hide::desktop::outlet":"0","summary::hide::desktop::temperature":"0","summary::hide::desktop::humidity":"0","summary::hide::desktop::luminosity":"0","summary::hide::desktop::power":"0","summary::hide::mobile::security":"0","summary::hide::mobile::motion":"0","summary::hide::mobile::door":"0","summary::hide::mobile::windows":"0","summary::hide::mobile::shutter":"0","summary::hide::mobile::light":"0","summary::hide::mobile::outlet":"0","summary::hide::mobile::temperature":"0","summary::hide::mobile::humidity":"0","summary::hide::mobile::luminosity":"0","summary::hide::mobile::power":"0","summary":{"security":[],"motion":[],"door":[],"windows":[],"shutter":[],"light":[],"outlet":[],"temperature":[],"humidity":[],"luminosity":[],"power":[]},"useCustomColor":"1"}',        'display' => '{"icon":"<i class=\"icon techno-robot30\"><\/i>","tagColor":"#011893","tagTextColor":"#ffffff","dashboard::size":"","sendToApp":"0"}',        'image' => '[]',        '_child' =>        array (       ),        '_changed' => false,        '_summaryChanged' => false,     )),      '_needRefreshWidget' => false,      '_timeoutUpdated' => false,      '_batteryUpdated' => false,      '_changed' => false,   )),    '_needRefreshWidget' => NULL,    '_needRefreshAlert' => NULL,    '_changed' => false, ))
[2020-08-03 15:56:44][DEBUG] : execute:: this:array (   'command' => 'copy',   'source' => '/var/www/html/backup',   'destination' => '/jeedom-bk',   'include' => '',   'exclude' => '',   'minage' => '',   'maxage' => '', )
[2020-08-03 15:56:44][ALERT] : Starting task (SauvegardeFTP/SaveFTP #908)
[2020-08-03 15:56:44][DEBUG] : execute:: pid:'17079' rclone:'/var/www/html/plugins/cloudsyncpro/3rparty/rclone-v1.41-linux-amd64/rclone -v --log-file /var/www/html/core/class/../../log/cloudsyncpro.#908 --config /var/www/html/plugins/cloudsyncpro/core/config/rclone.conf copy \'/var/www/html/backup\' 127:\'/jeedom-bk\''
[2020-08-03 15:56:54][DEBUG] : execute:: statistics:array (   'Errors' => NULL,   'Checks' => NULL,   'Transferred' => NULL,   'Elapsed time' => NULL,   'Bytes Loaded (Speed)' => NULL, )
[2020-08-03 15:56:54][ERROR] : Erreur exécution de la commande [Mobile et software][SauvegardeFTP][SaveFTP] : Task finished on Error (SauvegardeFTP/SaveFTP #908)

Et #908 :

2020/08/03 13:56:44 ERROR : Couldn't find home directory or read HOME or XDG_CONFIG_HOME environment variables.
2020/08/03 13:56:44 ERROR : Defaulting to storing config in current directory.
2020/08/03 13:56:44 ERROR : Use --config flag to workaround.
2020/08/03 13:56:44 ERROR : Error was: user: Current not implemented on linux/amd64
2020/08/03 13:56:44 ERROR : ftp://monsite.com:21/jeedom-bk: Error while Logging in into monsite.com:21: Unknown command
2020/08/03 13:56:44 Failed to create file system for "127:/jeedom-bk": NewFs: ftpConnection Login: Unknown command

Je n’ai pas touché à la config du plugin, ni à ma conf FTP.
J’ai réinstallé les dépendances, testé mes identifiants FTP, check des droits sur les fichiers à backuper, etc…

As-tu fait une mise à jour récente du plugin ?

Ce fichier existe toujours ?

Le fichier existe toujours oui et il contient la conf FTP.

EDIT : j’ai la dernière version du plugin.

Est-ce que le serveur FTP est accessible de l’extérieur ?
Si aucune mise à jour récente pour Jeedom, qu’en est t’il pour le serveur FTP ?

Je n’ai jamais eu auparavant ce type d’erreur et je suis quelque peu perplexe.

Des MAJ sur Jeedom, j’en fais dès qu’il y a un plugin qui doit se mettre à jour.
Si je regarde les dates des plugins, le 30 juillet, il y a eu geotrav.

Le serveur FTP est accessible de l’extérieur oui, c’est chez un hébergeur. Je n’y touche pas.

Penses-tu que je puisse avoir accès à ce serveur FTP que je puisse investiguer d’ou vient le problème ?
Il me suffit d’un login/password read/only

Hello @thanaus,

J’ai testé sur ma maquette, même souci.
J’ai testé avec un autre répertoire distant, un autre user, toujours pareil.
Il faudrait que je teste avec un backup de prod de la semaine dernière…

Concernant l’accès, non, c’est compliqué. C’est un serveur distant non dédié et donc pas de root sur la machine complète. De plus, il faut autoriser ton IP.

J’ai envoyé un mail au support (hébergeur) pour voir s’il y a eu des MAJ.
Ils m’ont répondu en moins de 10 minutes… Pas de modifications.
Ils me demandent plus d’infos.

Bon, je viens d’installer rclone sur ma machine pour test.
J’ai exactement la même erreur. Je viens de répondre au support (de l’hébergeur).

Le problème ne vient pas du plugin.
Je t’ai embêté pour rien @thanaus.

Je vais voir ce que le support me répond.
Suivant la réponse, je l’a posterais ici… Au cas où quelqu’un se trouve dans la même situation.

Merci pour tous ces retours…

Je pense qu’il y a vraiment eu une mise à jour de ton serveur FTP car le plugin cloudsyncpro n’a pas été mise à jour depuis quelques semaines voir plus.

En parallèle, je vais faire quelques tests avec un serveur FTP sur le port 21.
Je te tiens bien entendu au jus.

J’ai continué mes tests.
Aucun souci via rsync (depuis ma machine) ou via SFTP (plugin).

J’attends quand même le retour du support pour voir.

Tu utilises le plugin CloudSyncPro ? Si oui et que tout fonctionne, je te conseille de rester avec ce protocole.

Oui, c’est bien avec CloudSyncPro.
Je sais que c’est mieux mais je ne peux pas créer d’autres comptes qui ont un accès SSH. Uniquement mon compte principal.
Et je voulais un compte dédié pour cette sauvegarde.

Un retour de ton provider ?
Peux-tu cloturer ce topic car je ne pense pas que le problème soit le plugin comme discuté précédemment.

Hello,

Pas de retour utile et selon eux pas de MAJ.
Je ne sais donc pas ce qui s’est passé.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.