Clé Huawei E3372H

Tags: #<Tag:0x00007f28371a8e50>

Bonjour,
Le sujet a été effectivement traité au moins un milliers de fois. J’ai parcouru ceux-ci, cependant, je rencontre un cas de figure que j’ai trouvé nulle part.
Le contexte:
J’utilise la V4 de jeedom dans un environnement ESXi 6.7 avec une debian 10.
La clé Huawei est bien reconnue et elle est rattachée à la VM.
Le plugin SMS est installé, un équipement est paramétré.
Lorsque je lance le démon, il plante au bout de quelques secondes avec un message d’erreur « CMS 500 » (voir fichier attaché). sms.txt (9,3 Ko)
Curieusement, la clé dispose de 3 ports tty/USB1,2,3. J’ai bien évidemment testé les 3, sans succès.

Question:
Quelqu’un a t-il une idée de piste où chercher ?
Merci d’avance

La piste la plus prometteuse semble être celle de Google.

https://www.google.com/search?q=at+cms+error+500

Bonjour,
Merci pour ton retour.
J’ai bien évidemment exploré cette piste. Cependant une erreur CMS 500 est une erreur générique inconnue dont les causes peuvent être multiples et souvent inconnues !!!
Ma question est plus centrée sur l’usage de ce type de clé avec le plugin sms.
D’autres idées ?

Si je t’ai envoyé sur cette piste, c’est que d’après tes logs, il y a bien une discussion AT entre le plugin et ta clé. Ce qui me laisse penser que le problème est peut être entre la carte sim et le réseau de ton opérateur d’où mon lien vers Google :

CMS Error 500
In some cases you may receive a CMS Error 500 error message from your modem. This error message indicates, that for some reason the modem was not able to deliver the message. This error can happen if:

The phone number you try to send your message to is invalid
There is no network coverage
You don't have enough money on a prepaid subscription
The short message service center of the GSM network operator is temporarily out of service
The GSM cell is overloaded 

Je comprends.
J’ai fait le test avec ma carte sim (opérateur Free) en version native de la clé (Hilink) et je ne rencontre aucun problème pour émettre et recevoir des sms.
Néanmoins, pour être reconnue par le plugin, la clé doit être en mode modem et non pas routeur. J’ai donc reflashé le firmware en mode switch et là elle est bien reconnue mais ne fonctionne pas pour autant.

Une copie écran de ta page configuration serait la bienvenue.

Et voilà

Capture10

Je sèche…

Nous sommes deux :upside_down_face:

Le code pin ?
La force du signal !

akenad :slight_smile:

Déjà tenté mais malheureusement sans succès

Tu n’as pas de code pin pour ta sim ???!!!

akenad :slight_smile:

Si absolument, mais j’ai déjà fait l’essai avec et sans
Le résultat est le même

Avec il y a des chances que ca marche mieux. C’est juste une remarque sur la base du log et de la page de config fournie …

des infos ici : [Présentation] akenad

$ dmesg | grep USB

et

$ dmesg | grep GSM

akenad :slight_smile:

Bonjour,

Merci de ton retour.
Je viens de faire la manip. sans succès
J’ai une clé E3372H-607 et pas 153. Est-ce que le fichier de paramétrage de modeswitch doit être le même. Dans son nom et dans son contenu ?
Merci de tes retours

Je n’ai pas l’expérience de la clé « E3372H-607 » (tu devrais préciser dans le titre de ton sujet d’ailleurs), de plus tu as reflashé le firmware, ce que je ne conseille pas.
Par ailleurs cette clé ne semble pas porter clairement le logo Huawei sur sa face avant (photo site marchand).
La valeur sûr reste la clé Huawei E3372h-153.

Si tu veux avoir une chance d’être aidé par quelqu’un d’autre, je te suggère de publier le résultat des commandes indiquées dans mon post précédent.

akenad :slight_smile: