Camera EZVIZ compatibles?

Tags: #<Tag:0x00007f3853684fb0>

bonjour,

j’ai lu les infos sur le plugin hikvision, et avant de l’acheter j’aurai voulu trouver une confirmation…
est ce que les camera EzViz CS-CSV310 seraient compatibles ?

en effet, on a la possibilité d’ajouter ces camera dans l’app Hikvision (tout autant que sur l’appli « normale » ezviz) je me dis qu’il y a une chance que ces cam utilisent le même protocole et comme noté dans la doc du plugin, ça pourrait le faire…
pour info, ces cameras ont bien la détection de mvt (avec push sur les appli, etc) et ont un flux RTSP (elles fonctionnent actuellement sur le plugin camera mais juste pour avoir un retour de flux vidéo)

si quelqu’un a une idée ou même si quelqu’un a carrément testé, ça serait top :slight_smile:
un grand merci.

Personne n’a pu faire le test ?
Au besoin je peux tester le plugin avec la cam pour confirmer ou pas (s’il existe une version test, pour ensuite l’acheter j’entends)?
Merci.

Bonjour j’ai également des soucis d’intégratiion de ma CAMERA EZVIZ, donc si vous trouvez une solution je veux bien!!

Bonjour, je suis également preneur de cette information ayant 2 caméras EZVIZ. J’ai tenté une intégration IFTTT pour recevoir les alertes, mais je reçois seulement une notification par heure ! (et encore … depuis 2j je ne reçois plus rien)

Merci

Bonjour, même problème … j’ai acheté le plugin (bon c’est 5 € ça va) et tenté d’intégrer la caméra EZVIZ C3X. J’arrive bien à faire fonctionner le logiciel HikVision client (port 8000) donc je me suis dit que ça pourrait fonctionner.

Après quelques soucis lors de l’installation (droits sur le dossier /root, probablement nodejs foiré sur mon raspberry pi) les dépendances semblent installées même si j’ai ces messages dans le journal :

npm WARN notsup Unsupported engine for http2@3.3.7: wanted: {"node":">=0.12.0 <9.0.0"} (current: {"node":"12.18.3","npm":"6.14.6"})
npm WARN notsup Not compatible with your version of node/npm: http2@3.3.7

J’ai configuré la caméra (IP et port à 8000 avec utilisateur admin et mot de passe que j’utilise dans l’appli HikVision) mais lorsque le démon démarre cela remonte dans le journal Hikvision_node :

Connection error: Error: read ECONNRESET
events.js:292
throw er; // Unhandled 'error' event
^
Error: read ECONNRESET
at TCP.onStreamRead (internal/stream_base_commons.js:205:27)
Emitted 'error' event on CameraEventHandler instance at:
at CameraEventHandler.handleError (/var/www/html/plugins/hikvision/resources/node_modules/cameraeventhandler/dist/cameraEventHandler.js:186:14)
at Socket.<anonymous> (/var/www/html/plugins/hikvision/resources/node_modules/cameraeventhandler/dist/cameraEventHandler.js:49:42)
at Socket.emit (events.js:315:20)
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
errno: 'ECONNRESET',
code: 'ECONNRESET',
syscall: 'read'
}

@lunarok, une idée sur cette probable incompatibilité ? Est-ce un problème d’installation ou finalement une erreur de comm parce que le plugin ne cause pas comme la caméra le souhaite ?

Tu as essayé en renseignant le password sur l’étiquette de la cam ?
Je crois avoir lu qu’il fallait utiliser ce mot de passe et non celui de l’appli.