Bug version Beta V:1.1.7

Tags: #<Tag:0x00007f385d126820>

Salut,

Je viens d’installer la bêta de ce matin (1.1.7) et : j’ai 3 anomalies :

1°) L’image pour mon TH16 n’apparaît pas :

image

2°) les commandes On, Off, Vitesse 1 2 3 du ventilateur de mon IFan02 ne marche plus.
voici les logs du Ewejee_node :


(node:17664) UnhandledPromiseRejectionWarning: TypeError: Cannot set property 'switches' of undefined
    at /var/www/html/plugins/ewejee/core/js/newserver.js:317:43
    at /var/www/html/plugins/ewejee/core/js/newserver.js:334:14
    at Layer.handle [as handle_request] (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/layer.js:95:5)
    at next (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/route.js:137:13)
    at Route.dispatch (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/route.js:112:3)
    at Layer.handle [as handle_request] (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/layer.js:95:5)
    at /var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:281:22
    at param (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:354:14)
    at param (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:365:14)
    at param (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:365:14)
    at Function.process_params (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:410:3)
    at next (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:275:10)
    at expressInit (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/middleware/init.js:40:5)
    at Layer.handle [as handle_request] (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/layer.js:95:5)
    at trim_prefix (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:317:13)
    at /var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:284:7
    at Function.process_params (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:335:12)
    at next (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:275:10)
    at query (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/middleware/query.js:45:5)
    at Layer.handle [as handle_request] (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/layer.js:95:5)
    at trim_prefix (/var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:317:13)
    at /var/www/html/plugins/ewejee/core/js/node_modules/express/lib/router/index.js:284:7
(node:17664) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 3)

3°) Pas changement de statut Online :
Même constant pour tout les devices.
que mes devices soient connecter ou pas, je n’ai pas de changement d"état :

image

Je suis dispo, si tu as besoin de plus d’info.
Bon courage !
Dji

Salut,

Peux tu vérifier que tu as la toute dernière mise à jour ?

Pour le th16 je vais l’ajouter.

Pour le statut online il faut lancer une commande et le statut passera offline, tu peux confirmer ?

J’ai bien la dernière version du plugin :

image

je confirme qu’après avoir lancer une commande le statut ce met à jour.

Pour Ifan02, as tu besoin de plus d’info ?

Il me semblait avoir corrigé ce problème, je regarde ça ce soir après le travail, je te tiens au courant

1 J'aime

As tu bien les commande comme ceci :

image

ON lumière / OFF Lumière etc… ?

Si non, il faudra le supprimer cet equipement et refaire une synchronisation car j’ai du modifier les commandes pour palier à cette erreur.

C’est corrigé, tu peut faire la mise a jour que je viens de mettre en ligne et surtout relancer le démon une fois la mise a jour faire.

Hello,
Je viens de faire la MAJ.
Le ventillateur ON / OFF / Vitesse 1, 2, 3 fonctionnent nickel !
MERCI

il ne reste que le problème de l’image pour le TH16 :
Dans le tableau Mes Ewejee : la vignette du TH16 semble être hérite du ventilateur :
image

Mais dans l’édition du device, elle reste manquante :
image

Ce sera corrigé sur la prochaine MAJ normalement

1 J'aime

Alors moi je n’ai jamais eu aucune photo !
Après cela ne me dérange pas pour autant tant que tout fonctionne !

Salut,

Ça dépend des appareils, j’en ai mis très peu, je vais les ajouter sur la prochaine mise a jour, mais avec le confinement, mon travail me prend tout mon temps car on a trop de boulot, donc ce sera pas tout de suite

T’inquiète pas, comme je disais, tant que cela fonctionne …
Bon courage pour ton confinement, je comprend car je fais partie de ces personnes qui n’ont pas arrêté d’aller au travail ! :smirk:

1 J'aime