Bêta Plugin Lightmanager

Tags: #<Tag:0x00007f75271b2e90>

Bonjour,

J’ai acheté le plugin Lightmanager mais je n’ai pas fait attention qu’il était en Beta.
Bref c’est pas grave.

J’ai l’impression que la temporisation ne fonctionne pas car la lumière s’'éteint dès que le PIR repasse à Zero.

Bonjour
Bizarre pour m’en servirai des dizaines de fois pas jour je n’ai jamais vu de soucis, es tu sur de ta configuration ? As tu regardé la log ?

Dans le log par exemple j’ai ca.
detection du mouvement allumage à 19h37
extinction à 19h40 alors que j’ai mis 15 min de délai.

A moins que ca soit mon paramètre sur la luminosité que j’ai mal mis?

[2021-10-12 19:37:29][DEBUG] : [Cuisine][Cuisine Lumière] Turn on light
[2021-10-12 19:39:32][DEBUG] : [Cuisine][Cuisine Lumière] autoMotionLightOff => {"lightmanager_id":341,"seconds":"29"}
[2021-10-12 19:39:32][DEBUG] : [Cuisine][Cuisine Lumière] #6998# result : 1
[2021-10-12 19:39:32][DEBUG] : [Cuisine][Cuisine Lumière] Motion check => 1
[2021-10-12 19:39:32][DEBUG] : [Cuisine][Cuisine Lumière] motion in progess do nothing
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] mainMotionChange => {"lightmanager_id":341,"event_id":"6998","value":"0","datetime":"2021-10-12 19:40:44","listener_id":"10"}
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] handleStateLight
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] Light state check => 1
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] #6998# result : 0
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] Motion check => 0
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] No motion check off light
[2021-10-12 19:40:44][DEBUG] : [Cuisine][Cuisine Lumière] Light is on plan off light

Ca je peux pas te dire seul toi peux savoir en regardant la configuration la vu la log ça a pas l’air bien configuré

As-tu vérifié si dans les paramètres de tes lampes il n’y a pas un paramètre d’extinction automatique à une valeur différente de jamais ?

Non c’est un simple SHelly sans aucune config spéciale.
ca fonctionne avec mon scénario qui est désactivé pour mon test bien sur.

les paramètres dans le plugin sont simples.
j’ai mis 15 minutes de délai apres absence il éteint apres 5 minutes.

c’est ce que je vois dans les logs.

Je viens de mettre 15 minutes de delai et je vois le cron que se mets bien.
je vais surveiller.

Quand le plugin passera t’il en stable?

Comme toujours chez jeedom jamais de date ça peut-être demain comme dans un an

1 J'aime

Ok :slight_smile:

une derniere question pour que je comprenne et c’est peut etre la le souci.
je vois dans les cron qu’il créé plusieurs crons à chaque fois au lieu de recalculer de garder un seul.

image

du coup il prend le premier cron initialement créé au lieu de celui qui est le plus loin dans le temps.
est ce normal?

Il se débrouille normalement tu n’as pas a t’inquiéter de cela

J’en profite car je l’ai testé… il y a un soucis, car à chaque fois que je passais devant un détecteur de mouvement il a créé un cron, et quand les taches se terminaient une par une il éteignait la lumière. Donc au bout d’un time out il éteint la lumière autant de fois que de cron…

Édit j’avais fait un sujet il y a quelques semaines mais je n’avais pas eu de retour.

Ok je note je corrigerai le jour où je trouve le temps merci pour le retour

Ça me rassure c’est le cas que je décris.
Les crons se sont créés a chaque détection de mouvement.

Merci Loïc je passe le sujet en solution et en attendant je vais garder mon scénario.

A tester avec la beta de ce matin peut etre que ca fera un truc (mais sans conviction), j’arrive vraiment pas a reproduire chez moi

Je vais tester ça.
Je suis avec PIR aqara je sais pas si ça peut aider

J’ai le même pourtant après je suis en core alpha ça peut venir de la

Toujours Pareil.
Je te laisse voir ca quand tu peux :wink:

Vraiment bizarre il me faudrait la log en debug la

lightmanager.log (2,9 Ko)

Bonjour Loic,
J’ai refait un test propre et voici le log.

mon constat:
Il détecte la mouvement, la lumière s’allume.
lorsque le PIR repasse à zéro, il planifie un cron avec le bon timer.
Si je repasse devant le PIR alors que la lumière est allumée, il lance comme même une commande On.
Le PIR repasse à Zéro, un nouveau cron est planifiée pour autant l’ancien n’est pas supprimé.
Résultat au bout d’un moment il exécute les différents CRON au lieu de ne garder que le plus ancien.
image

Autre point que j’ai pu voir mais que j’ai pas mis dans le log, si aucun détecteur de lumière n’est paramétré, il considère la valeur à Zero et du coup n’allume pas sur la simple détection de mouvement.
Cela est gênant car certains PIR n’ont pas la valeur de lux.

Je suis en Jeedom V4.1.26.
Mon module lumière est un shelly 1
Mon PIR est un Aqara.

En espérant que ca puisse aider.

Bonjour,
Merci je vais regarder pour le soucis sans détecteur de luminosité c’est normal et bien le fonctionnement attendu le plugin ne peut pas fonctionner sans, il n’est pas prévu d’évolution la dessus.