Anomalie widgets intégrés

Tags: #<Tag:0x00007fa7b0a31fb0>

Bonjour,
quelques soucis repérés avec les widgets intégrés à un widget (dans mon cas j’ai créé un widget imprimante comportant des widgets de niveau d’encre) :

  • si l’on tente d’accéder au détail des widgets intégrés, on obtient une erreur (il faudrait peut-être bloquer l’accès aux détails si ce n’est pas implémenté)
  • en supprimant les widgets intégrés, sans toucher au widget qui les contient, le widget qui les contient continue à les afficher mais il devient inaccessible (on peut heureusement le supprimer de la configuration du smartphone).

Je me retrouve avec un widget non sélectionnable, donc non supprimable, y-a-t-il moyen de reprendre la main dessus ?

(donner la version serait une bonne info aussi pour commencer :wink: )

doublon ?

est ce que tu as essayé de rafraichir la configuration sur le tel ?
tu peux partager un screen de ce à quoi ressemble ton « widget qui les contient » là maintenant ?

Pardon : je suis en beta avec tous les éléments les plus récents

Sur le détail oui c’est un doublon, je chercherai mieux la prochaine fois :confused:

Le widget qui les contenait, en le remettant sur le smartphone (car c’est encore possible), apparaît à présent bien sur le smartphone sans les widgets intégrés.
Le souci restant est qu’il n’est plus accessible depuis le plugin.
Le plugin génère des erreurs « https://URLJEEDOM/index.php?v=d&m=JeedomConnect&p=JeedomConnect line 2 > injectedScript 2210 TypeError: widget is undefined » lorsqu’on insiste en cliquant dessus
Je précise aussi que le widget en question est un générique binaire

juste pour essayer de comprendre ce que tu as fait

tu partais d’un widget binaire qui contenait plusieurs autre widget (ici 3 autres ‹ abs tom ›, ‹ ami ›, ‹ big list ›), comme ça :
image

et ensuite tu as supprimé un (tous) les widgets parmis ‹ abs tom ›, ‹ ami ›, ‹ big list › => mais les widgets eux même
pas en cliquant simplement sur le sens interdit de l’image d’au dessus, mais en ouvrant le widget ‹ abs tom › par exemple, et en cliquant sur supprimer.

c’est ca ?

Exactement

oki !

et maintenant si tu essaies d’ouvrir le widget parent ‹ Alarme garage › dans mon exemple, il ne s’affiche pas et met un msg d’erreur ?

Oui : sous firefox, ça semble rafraichir quelquechose à l’écran, et le message d’erreur s’ajoute dans les logs Jeedom.

Si ça peut aider, par rapport à ton exemple, j’ai en plus quelques commandes infos et des images sous condition dans le widget.

bon je crois voir d’où ca vient. je vais regarder pour fixer ça. :slight_smile:

(le probleme doit d’ailleurs déjà exister depuis un bout de temps si on fait la meme manip sur un favoris ou un résumé ! )

en attendant pour ton cas et pour virer l’erreur, est ce que tu peux aller sur ton équipement JC, et cliquer sur le bouton partager (tout en bas du bouton assistant) et m’envoyer en MP le fichier qui a été généré.

1 J'aime

cool plus qu’à tester et confirmer si c’est ok lors de la prochaine livraison.

:+1:

Avant fermeture, cela me semble lié au sujet,

on ne peut pas ajouter de widget résumé ou favoris dans un widget en vue détail. par exemple j’ai un widget alarme auquel j’ajoute un widget action ça c’est ok, mais je souhaite ajouter un widget favoris qui contient 3 widget switch et la j’ai la méchante tête de mort. Bug? ou normal vu que favoris et résumé regroupe déjà plusieurs widgets?

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.