Amelioration plugin-zigbee

Tags: #<Tag:0x00007fcbad556ad8> #<Tag:0x00007fcbad556a10>

Bonjour,

Je teste le plugin zigbee avec des ampoules ali.

Elles remontent sans constructeur ni rien mais remonté bien sous deconz et sous jmqtt.

{
    "ieee": "00:12:4b:00:22:6d:5f:63",
    "nwk": 63251,
    "status": 2,
    "lqi": "247",
    "rssi": "-63",
    "last_seen": "1617869876.0697794",
    "node_descriptor": "01:40:8e:00:00:50:a0:00:00:00:a0:00:00",
    "endpoints": [
        {
            "id": 1,
            "status": 1,
            "device_type": 528,
            "profile_id": 49246,
            "manufacturer": "eWeLight",
            "model": "ZB-CL01",
            "output_clusters": [],
            "input_clusters": [
                {
                    "id": 0,
                    "name": "Basic",
                    "attributes": [
                        {
                            "id": 4,
                            "name": "manufacturer",
                            "value": "eWeLight"
                        },
                        {
                            "id": 5,
                            "name": "model",
                            "value": "ZB-CL01"
                        },
                        {
                            "id": 7,
                            "name": "power_source",
                            "value": 1
                        }
                    ]
                },
                {
                    "id": 3,
                    "name": "Identify",
                    "attributes": []
                },
                {
                    "id": 4,
                    "name": "Groups",
                    "attributes": []
                },
                {
                    "id": 5,
                    "name": "Scenes",
                    "attributes": []
                },
                {
                    "id": 6,
                    "name": "On\/Off",
                    "attributes": []
                },
                {
                    "id": 8,
                    "name": "Level control",
                    "attributes": []
                },
                {
                    "id": 768,
                    "name": "Color Control",
                    "attributes": []
                }
            ]
        },
        {
            "id": 13,
            "status": 1,
            "device_type": 57694,
            "profile_id": 49246,
            "manufacturer": null,
            "model": null,
            "output_clusters": [
                {
                    "id": 4096,
                    "name": "LightLink",
                    "attributes": []
                }
            ],
            "input_clusters": [
                {
                    "id": 4096,
                    "name": "LightLink",
                    "attributes": []
                }
            ]
        }
    ],
    "signature": {
        "manufacturer": "eWeLight",
        "model": "ZB-CL01",
        "node_desc": {
            "byte1": 1,
            "byte2": 64,
            "mac_capability_flags": 142,
            "manufacturer_code": 0,
            "maximum_buffer_size": 80,
            "maximum_incoming_transfer_size": 160,
            "server_mask": 0,
            "maximum_outgoing_transfer_size": 160,
            "descriptor_capability_field": 0
        },
        "endpoints": {
            "1": {
                "profile_id": 49246,
                "device_type": 528,
                "input_clusters": [
                    0,
                    3,
                    4,
                    5,
                    6,
                    8,
                    768
                ],
                "output_clusters": []
            },
            "13": {
                "profile_id": 49246,
                "device_type": 57694,
                "input_clusters": [
                    4096
                ],
                "output_clusters": [
                    4096
                ]
            }
        }
    },
    "class": "zigpy.device"
}

Voici le json brute.

Et en complément les infos jmqtt

Friendly name 0x00124b00226d5f63

Device type Router

Zigbee model ZB-CL01

Description Zigbee 3.0 LED-bulb, RGBW LED

Support status Supported

IEEE address 0x00124b00226d5f63

Network address 0xF713

Firmware build date 20201216

Firmware version 1.0.13

Vendor Lonsonho

Model ZB-RGBCW

Power source Interview completed

J’en ai 5 qui viennent de vendeurs différent mais toujours de Ali, elles sont toute de la même marque et sur les boites, compatible Hue.

Bonjour,

l’ampoule apparait maintenant dans le choix mais les commandes ne fonctionne pas. seulement le changement de couleur.

Voici le message d’erreur :

Erreur lors de la requete : http://127.0.0.1:8080/device/command(PUT), data : {"ieee":"00:12:4b:00:22:6d:5f:63","cmd":[{"endpoint":1,"cluster":"on_off","command":"on","await":1}],"allowQueue":false} erreur : {"state":"error","result":"Device not found","code":0}