Aide déblocage scenario resté "en cours"

Bonjour,

Je suis utilisateur de Jeedom sur un rpi avec une zibase comme émetteur/récepteur et le pluggin jeebase pour communiquer avec.
Tout va bien la plupart du temps, mais certains de mes scénarios restent bloqués. Ils apparaissent comme “en cours”, je peux les arrêter et tout reprend comme avant.
Dans un premier temps j’ai cru que c’était à cause de scénari complexes qui utilisaient des scripts pour éteindre et allumer les diodes sur ma zibase (car j’avais des messages d’erreur de communication avec la zibase concernant ces erreurs d’allumage de diodes qui semblait correspondre au scenario et à l’heure de son blocage).
J’ai donc arrêter de faire joujou avec les LEDs et enlevé tous les scripts, mais les problèmes subsistent.
J’ai même un scenario ultrasimple qui est resté coincé hier : celui d’allumage à 21h d’une prise commandée.

Pouvez vous m’aider à chercher dans la bonne direction, activer les bons logs pour essayer de débloquer cette situation.

Vu le scenario qui est resté bloqué hier, ça pourrait être un problème de jeedom core ou un problème de pluggin jeebase ?

Merci d’avance pour vos réponses et je suis dispo pour des précisions.

Benoît.
RPI 3, zibase, jeebase

Quelle version de Jeedom ?

Si en V3, à jour ?

çà a été détecté puis corrigé en V3 il y a plusieurs mois

oui oui, tout est à jour quasiment en permanence, le temps que je me rende compte d’une MAJ.
et le rpi est à jour aussi, j’essaye d’y penser tous les mois.

Aucune idée si c’est un problème similaire, mais j’ai eu des scénarios qui bloquaient aujourd’hui avec ce message :

La dernière exécution du scénario ne s’est pas lancée. Vérifiez le log scenario_execution, ainsi que le log du scénario “Buanderie”.

J’ai relancé une sauvegarde et fait une restauration les droits depuis la page configuration et c’est passé. Au vu des logs et dates de collecte, presque sûr que c’est la sauvegarde qui a débloqué les choses.

Voilà, c’est juste une piste. Pour info, je suis en version 3.3.38.

Je n’ai rien dans le log scenario_execution, je n’ai pas trouvé comment l’activer…

Pouvez vous m’indiquer comment activer le max de log pour les scénarios… quand je vais sur le log du scenario qui a bloqué cette nuit, j’ai la trace de l’occurence précédente à 4h11 mais pas la suivante qui aurait dû se faire à 4h21 et aucune par la suite.

Je suis aussi en 3.3.38 depuis hier, et cette nuit, encore un scenario qui ne fait qu’éteindre un chauffage via jeebase/zibase/xd2 toutes les 10min.

Pour l’instant, sur chaque scenario qui bloque, j’autorise les excécutions multiples, mais ça me plait pas trop comme solution.

Salut,

C’est peut-être pas le max de log dont tu as besoin mais les logs en temps réel. Par défaut, je pense que les logs ne sont enregistrés qu’en fin de scénario…
image

Ok, je vais faire ça et voir ce que ça écrit… je pensais qu’il y avait une option générale, pas de devoir passer tous les scénarios un par un en mode temps réel… vu que c’est pas toujours le même qui coince, je vais tous les activer.

Merci.

Bon, ça continue à bloquer de temps en temps… j’ai fini par réussir à activer le temps réel, j’ai même créer un faux scénario qui s’exécute toutes les minutes et qui active et désactive via le plugin jeebase un actionneur. Par contre pas de chance, je me suis rendu compte que le scénario a bloqué ce matin, mais que le log temps réel n’était pas assez long pour remonter jusqu’à la bonne heure.
Je vais me créer un scénario pour me signaler suffisamment rapidement le souci pour pouvoir lire le temps réel avant qu’il disparaisse.

Bonjour,
J’ai eu cela moi aussi, depuis je reboot la jeedom 1 fois par semaine et plus de problème.

Salut j’ai déjà eu le même problème, également avec une zibase et jeebase. J’ai mis un timeout sur les scénarios, ça ne l’a pas refait mais c’était très rare donc on verra bien. Je n’avais même pas imaginé que ça puisse venir de jeebase par contre.