Affichage widget action binaire sur ampoule

Tags: #<Tag:0x00007fe3246d12d0>

Salut à tous, j’ai une soucis d’affichage de widget que je n’arrives pas à résoudre en V3 comme en V4 !
Je crée un widget action avec 2 images : classique…
Je l’applique sur les cde on/off de mes prises connectés de marques différentes : ça fonctionne parfaitement, les images s’affichent successivement selon l’allumage ou l’extinction…
Mais si j’applique sur mes ampoules 2 images s’affichent et sa ne fonctionne pas.

J’ai vu que les commandes d’ampoules ne sont pas on/off mais allumer/éteindre, mon problème est peut être la mais même en renomment les commandes, pas de résultat…

Quelqu’un à peut être la solution ?

Bonjour et bienvenue @benji130,

Peux-tu poster une copie d’écran des commandes d’une ampoule stp ?

widget

A gauche le résultat voulu en appliquant sur les CDE de prise spot
A droite le problème en appliquant sur les CDE de lampe ilot centre (ampoule YEELIGHT)

Plutôt les commandes si tu peux stp (on, off, état)

Pas les commandes dans le Dashboard effectivement :wink:, celles dans le module. Elles ressemblent à çà :
Capture d’écran 2020-03-23 à 11.55.45

Yeelight il me semble que tu dois reprendre les commandes dans un virtuel

Les commandes d’origine
cde

Si je modifie les CDE en On/Off voici le résultat :

cde on_off

La commande On disparaît et la Off est fonctionnelle.

J’ai déjà essayé un virtuel mais même résultat…
Je m’y prends peut être mal !

Pourtant la solution est l’utilisation d’un virtuel.

Tu récupères les commandes allumer et éteindre et tu crées une info binaire que tu lies avec les 2 commandes action

Je penses en effet que c’est la solution mais que je dois mal configurer mon virtuel…
voici un exemple sur une ampoule yeelight standard.
Dite moi ce que vous en pensez…
cde virtuel

moi j’ai fait comme sa image

Bonjour Benj130,

Sur mes Yeelight j’ai fait l virtuel comme cela:

Capture

Ensuite tu applique ton widget v4 icon/action que tu aura fait sur les commandes ON/OFF et tu décoche afficher sur l’état.

Pour mon widget v4 je l’ai fait comme ça:

Capture1

Au final tu devrais avoir ton ampoule cliquable ON/OFF

2 J'aimes

J’ai tout repris à zéro, en effet mon virtuel n’était pas bon !
En tous cas merci beaucoup pour pour tes captures écran qui m’on permises de régler mon problème !
Ça fonctionne :grinning:
Pour info, ça fonctionne aussi en utilisant img au lieu d’icon et ça permet de modifier la taille du widget.

Bonjour,

Super content pour toi :slight_smile:

Oui je sais :wink:

Pense à cocher la case “solution” sur le message qui répond à la demande. ça fermera automatiquement la sujet et fera remonter la réponse sur le 1er post pour que ceux qui auraient la même demande visualisent immédiatement la solution.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.