Accès HTTPS avec certificat personnel

Bonjour,

Pour ça, il y a le challenge DNS (puisque tu gères ton domaine).

3 J'aimes

Pour ça, il y a le challenge DNS

Et en plus cela permet d’avoir un certificat wildcard.

2 J'aimes

Bonjour @henribi

J’ai commencé ton tuto mais j’ai une erreur à la commande suivante :

root@jeedom:~# mv /home/jeedom/star* sslcert
mv: cannot stat ‹ /home/jeedom/star* ›: No such file or directory

Je suis donc bloqué à ce niveau.
Merci pour la suite.

Bonjour,
à propos de procédure simplifiée, à une époque il existait un plugin qui faisait le boulot, il n’est plus maintenu mais ça serait une bonne idée de le remettre à jour non ?

1 J'aime

Bonjour,
Les noms de mes fichiers certificats sont star_henribi_be.crt et star_henribi_be.key.
Je suppose que tu as deux fichiers. Un qui est le certificat signé par ionos, par exemple fidjial.crt et l’autre ta clef privée en fidjial.key
Donc pour les déplacer du directory jeedom vers le directory sslcert, j’abrévie le nom des fichiers en star*.
Tu dois remplacer star_henribi_be par le nom de tes fichiers certificats fidjial*
Tu peux le faire en deux commandes mv fidjial.crt et mv fidjial.key

Bonjour @henribi

En fait c’est la copie de mes fichiers que je n’ai pas réussi à faire dans le directory jeedom.

Copy your certificate and key to the home directory of user « jeedom ». (You cannot do that with jeexplorer.)

Comment je peux copier mes 2 fichiers sans Jeexplorer ?
Je suis sur MacOS avec le Terminal.

Désolé si je suis lourd mais pas à l’aise avec les lignes de commandes :frowning_face:

scp #tonfichierenlocalsurtonmac# #utilisateurSSHsurJeedom#@#ipJeedom#:/tmp

Ainsi ton fichier sera dans le repertoire /tmp et tu n’auras plus qu’a faire depuis le SSH sur Jeedom un
mv /tmp/*** #repDeDestination#

Quand je glisse le fichier depuis le bureau sur le Terminal :

root@jeedom:~# scp /Users/alain/Desktop/_.toto.fr_private_key.key jeedom@192.168.10.132 :/tmp

J’obtiens ça en réponse :

/Users/alain/Desktop/_.toto.fr_private_key.key: No such file or directory

Pourtant le chemin de mon fichier doit être correct car je l’ai glissé ?
Merci.

Il faut pas être connecté sur le Jeedom pour la commande scp.
Tu ouvres juste le terminal Mac et tu lance la même commande.

Une fois la commande terminée, la tu peux te connecter à Jeedom en SSH

Merci @mguyard, il fallait être connecté sur le Mac bien sûr :upside_down_face:
Donc ça c’est fait.

Maintenant je bloque sur la commande suivante :

cp sites-available/000-default.conf sites-enabled/000-default-ssl.conf

En réponse :

cp: cannot stat ‹ sites-available/000-default.conf ›: No such file or directory

Le fichier n’existe pas où je fais une erreur ?
Merci.

A mon avis tu as oublié cette partie la de la procédure :
image

il faut faire un

cd /etc/apache2

Oui exact, je ne m’étais pas remis dans le bon dossier.

Pour la suite j’ai bien édité le fichier 000-default-ssl.conf comme suivant :

<VirtualHost toto.fr:443>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ErrorLog /var/www/html/log/http.error
SSLEngine on
SSLCertificateFile /etc/apache2/sslcert/toto.fr_ssl_certificate.cer
SSLCertificateKeyFile /etc/apache2/sslcert/_.toto.fr_private_key.key
</VirtualHost>

Et ensuite les commandes suivantes ont bien été exécutées :

cd mods-enabled
ln -s …/mods-available/ssl.conf ssl.conf
ln -s …/mods-available/ssl.load ssl.load
ln -s …/mods-available/socache_shmcb.load socache_shmcb.load cd /etc/apache2

Ensuite vérification de la config :

AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‹ ServerName › directive globally to suppress this message
Syntax OK

Apache Stop :

AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‹ ServerName › directive globally to suppress this message

Apache Start :

Invoking ‹ systemctl start apache2 ›.
Use ‹ systemctl status apache2 › for more info.
Warning: apache2.service changed on disk. Run ‹ systemctl daemon-reload › to reload units.

Ca ne fonctionne pas.
Peut être l’adresse de connexion du sous-domaine qui est home.toto.fr ne correspond pas à toto.fr ?

Merci encore

le nom dns de ton Jeedom tu veux que ce soit quoi ?
Car ton nom dns doit etre ton vhost
Donc si tu veux un dns jeedom.toto.fr alors tu dois avoir :

<VirtualHost jeedom.toto.fr:443>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ErrorLog /var/www/html/log/http.error
SSLEngine on
SSLCertificateFile /etc/apache2/sslcert/toto.fr_ssl_certificate.cer
SSLCertificateKeyFile /etc/apache2/sslcert/_.toto.fr_private_key.key
</VirtualHost>

Pour ca normalement il te suffit de faire la commande

a2enmod ssl
a2enmod socache_shmcb

Merci pour ton support à l’utilisateur.
Je suis nettement moins présent que toi sur community.

Oui j’ai un excellent support :smiley:

Je viens de modifier avec le dns de connexion :

<VirtualHost jeedom.home.toto.fr:443>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ErrorLog /var/www/html/log/http.error
SSLEngine on
SSLCertificateFile /etc/apache2/sslcert/toto.fr_ssl_certificate.cer
SSLCertificateKeyFile /etc/apache2/sslcert/_.toto.fr_private_key.key
</VirtualHost>

Mais toujours la même réponse :

root@jeedom:/etc/apache2# apachectl configtest
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‹ ServerName › directive globally to suppress this message
Syntax OK

Et dans le log de jeedom :

[Fri Sep 10 14:56:45.357449 2021] [core:notice] [pid 22209] AH00052: child pid 22214 exit signal Bus error (7)
[Fri Sep 10 14:56:45.423447 2021] [core:notice] [pid 22209] AH00052: child pid 22211 exit signal Bus error (7)
[Fri Sep 10 14:56:45.423749 2021] [core:notice] [pid 22209] AH00052: child pid 22213 exit signal Bus error (7)
[Fri Sep 10 14:56:45.423953 2021] [core:notice] [pid 22209] AH00052: child pid 22351 exit signal Bus error (7)
[Fri Sep 10 14:56:45.687074 2021] [mpm_prefork:notice] [pid 22209] AH00169: caught SIGTERM, shutting down
[Fri Sep 10 14:56:56.761725 2021] [mpm_prefork:notice] [pid 15388] AH00163: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured – resuming normal operations
[Fri Sep 10 14:56:56.761934 2021] [core:notice] [pid 15388] AH00094: Command line: ‹ /usr/sbin/apache2 ›

Bonjour,
Et ? Ta connexion fonctionne ou pas ?

Car les messages ne sont que des messages d’information (que ce soit dans le test de configuration ou dans le log)

oui je me connecte bien en HTTP://jeedom.home.toto.fr:80

Et en https ? (car il me semble que c’est ce que tu veux)

Non bien sûr, ça ne fonctionne pas en https.
La page de connexion sur le navigateur :

Ce site ne peut pas fournir de connexion sécurisée

jeedom.home.toto.fr a envoyé une réponse incorrecte.

ERR_SSL_PROTOCOL_ERROR

Cette commande donne quoi ?

netstat -natp | grep 443